quinta-feira, 29 de maio de 2014

A fonte Argentina

3 comentários
Comprei uma fonte de alimentação no ferro velho (ou "reciclagem" com dizem atualmente) para reaproveitar o transformador. O critério que uso para comprar fontes lineares é por peso, quanto mais pesada melhor (trafo de maior potência). Esta aqui parecia ter mais de 1kg o que significa um transformador de mais de 50W ("rule of thumb", não sei uma expressão equivalente em Português).

Como sempre acontece nos ferros velhos a primeira coisa que eles tiram dos aparelhos são os cabos externos que são cortados no alicate o mais rente possível da caixa:
Parte frontal da fonte

Parte traseira da fonte
Pela lateral dava pra ver o transformador e alguns dissipadores. E dissipadores em uma fonte normalmente é um sinal de que a fonte é regulada. E fontes reguladas usam transistores de potência, que podem ser reaproveitados em outros projetos.
Lateral da fonte

Por dentro a fonte é bem compacta, aproveitando ao máximo a caixa de ferro:
Vista interna da fonte

A primeira impressão foi muito boa, além do transformador e capacitores eletrolíticos eu levei 3 transistores de potência pra casa, com os dissipadores. Mas como alegria de pobre dura pouco olhei com mais atenção e...
Transistores da fonte
Parece que encontrei o motivo da fonte ter sido jogada fora. Retirando o transformador para olhar melhor a coisa só piorava:
Placa da fonte

Retirei a placa da caixa e o estrago parecia bem grande:
Placa da fonte

Placa da fonte
Aquele componente no dissipador em cima ao centro, logo abaixo dos eletrolíticos é um LM317. Não dava pra ver pois ele estava embaixo do transformador. Medi os transistores e estavam em curto em todos os pinos. Retirei os três e o LM317 da placa na esperança de que ao menos um estivesse bom, mas todos tinham ido pro saco. Alguns diodos também não estavam bons e os eletrolíticos da área afetada estavam com a capa plástica com sinais de derretimento.

Olhando mais de perto dá pra ver um sinal do que pode ter acontecido:
Curto circuito na fonte

O cobre da placa sumiu naquele ponto, que fica bem embaixo do porta fusível. Talvez um curto de um dos pinos do porta fusível com a placa tenha jogado a tensão da rede diretamente ali, no terra da fonte. A coisa foi feia mesmo...

Pelo menos o transformador está bom (já testei) e é um trafo de 18+18V com corrente em uns 5A (chute meu). Olhando as marcações da fonte encontrei as seguintes informações:
Fabricante da fonte

Procurei na web sobre esta tal de "rialcom" e não encontrei nada. procurando pelos modelos MIX62 e MIX100 e a palavra "Argentina" (onde a fonte foi fabricada) cheguei na Trialcom (nunca use a primeira letra do seu nome no logo), fabricante de mesas de som (consoles) para estúdios de rádio. Dando uma pesquisada no site do fabricante descobri que esta fonte é justamente a fonte de alimentação destes consoles. Isso explica as duas saídas de alimentação simétrica (provavelmente de +15V e -15V para os amplificadores operacionais do mixer) e a saída de 48V ("Phantom Power" para microfones de estúdio).

quarta-feira, 28 de maio de 2014

Por dentro de um repelente de insetos elétrico

1 comentários
Minha esposa comprou este aparelho recentemente e não gostou muito dos resultados (aparelho ligado e mosquitos voando ao mesmo tempo). Como ele nunca mais seria usado e provavelmente seria esquecido no armário resolvi satisfazer minha curiosidade sobre o funcionamento.

O aparelho é este aqui (não lembro a marca e modelo):
Repelente elétrico

Ele funciona em 127 ou 220 VAC "automático". A parte de baixo é o refil com o líquido repelente e não interessa muito para nós aqui do blog (eu e meus 2 leitores) então fui direto na parte de cima:

Repelente elétrico
O refil tem um bastão que vai encaixado naquele buraco no centro. O bastão esquenta e evapora o liquido repelente. Esta parte aí é muito resistente e só abriu quebrando o plástico. E dentro tem o seguinte circuito:

Repelente elétrico

O esquema dele é bem simples:
Esquema repelente elétrico

A lâmpada Neon serve apenas para indicar que o aparelho está ligado. O fusível térmico está ali para o caso de as coisas ficarem muito quente lá dentro. Aquela peça preta com o furo onde vai encaixado o refil é um resistor de 4k7 Ohms que esquenta uma placa metálica. Desmontar isso daí deu trabalho, mas consegui:

Repelente elétrico

A resistência é aquele bloquinhos cinza na parte de baixo. O anel metálico esquenta, esquentando o bastão do refil. Funcionamento bem simples, pena que os mosquitos nem ligaram muito para o aparelho...

terça-feira, 27 de maio de 2014

Reduzindo o volume de um piano infantil

5 comentários
Comprei este piano para minha filha pequena e depois de uns 10 minutos de uso o brinquedo já se mostrou insuportável. O troço tem um volume muito alto e junto com os sons de animais e musicas com taxa de amostragem lá embaixo causam um significante desconforto auditivo. Depois de alguns dias achei melhor reduzir o volume a um nível mais tolerável (no máximo um cômodo e não mais o prédio todo).

O aparelho vem nesta caixa:
Caixa do piano de brinquedo
Tudo "nos conformes", com selo do Inmetro, nome do importador, site, endereço, etc e tal. O piano vem branquinho como na foto da caixa, mas após algumas semanas sendo jogado pra lá e pra cá ele já está um pouco sujo:
Piano de brinquedo

Se aguentou até agora sem quebrar nada já é um bom sinal. Mas só por segurança eu colei a tampa das pilhas com fita adesiva:

Por baixo do piano de brinquedo

Para reduzir o volume pensei em colocar um resistor em série com o alto falante. Para isso tive que abrir o brinquedo:
Placas das teclas do piano

As três placas grandes são só para as teclas. O circuito mesmo fica na plaquinha pequena montada na vertical:
PCB do piano de brinquedo
No suporte de pilhas um diodo solitário (1N4148) previne ligar o aparelho com as pilhas invertidas. E por falar nisso o fio azul é o positivo das pilhas e o vermelho (!) o negativo:
Diodo de proteção

Comecei a modificação com um resistor de 10 Ohms em série com o alto falante e fui subindo o valor até o volume ficar como eu queria. No final usei um resistor de 100 Ohms. Encontrado o valor ideal soldei e isolei com espaguete termo retrátil o componente no lugar. Aproveitei e ajeitei o diodo 1N4148 das pilhas, cortando os terminais e isolando:
Alto falante do piano de brinquedo

Para concluir, vejam as formas de onda no alto falante antes e depois do resistor no piano:
Forma de onda Antes
Forma de onda antes do resistor no alto falante do piano
Forma de onda depois
Forma de onda com o resistor em série com o alto falante do piano

quarta-feira, 14 de maio de 2014

Sirene com três transistores

1 comentários
Me lembrei de um velho esquema de uma sirene numa velha revista de eletrônica (acho que foi numa "Revista monitor de Rádio e TV") e tentei construir o circuito de cabeça (não tinha mais esta edição). Lembrava que tinha um oscilador clássico (multivibrador astável) com dois transistores na parte de baixa frequência e um oscilador com transformador para a alta frequência. Rabisquei alguns esquemas e fui testando até chegar neste aqui:

Esquema de sirene
Liguei o oscilador de alta frequência ao de baixa via emissor de Q3, embora eu tenha quase certeza que não era bem assim o original, mas funcionou. Coloquei um LED de 10mm na outra saída do multivibrador pra piscar. Testei alguns transformadores pequenos e o que ficou melhor foi um que eu recuperei de um Walkie talkie de brinquedo. Tudo montado no protoboard:


O som ficou um pouco estranho, mas gostei do resultado. Circuito meio inútil, mas foi divertido montar. A forma de onda no alto falante ficou assim:

Forma de onda na saída da sirene

E pra completar, um vídeo do circuito funcionando. Ele funciona bem quando alimentado com 9V, se subir um pouco ele fica só num tom continuo. E ele continua funcionando mesmo em tensões abaixo de 3V. No vídeo dá pra ouvir mesmo após o desligamento da fonte de alimentação, só na descarga do capacitor.

quinta-feira, 1 de maio de 2014

Modem Roteador TD-W8968 TP-Link

5 comentários
Já faz um tempo que eu estava pensando em trocar meu modem/roteador ADSL e acabei escolhendo o modelo TD-W8968 da TP-Link:
Modem roteador TD-W8968 TP-Link


O modem anterior era um Linksys (Cisco) WAG120N já com uns 3 ou 4 anos de uso e não é tão ruim assim. Na verdade é um modem muito bom, mas com o único detalhe de ter um alcance do Wi-Fi sofrível, principalmente por causa da antena interna. O resultado é que aqui em casa a rede sem fio mal chegava a uns 7 metros de distância, no meu quarto (apartamento estreito e comprido), com três paredes até lá.

Outro motivo da troca foi minha necessidade de um servidor de arquivos. Manter o PC ligado o tempo todo pra isso não é muito econômico e o TD-W8968 possui uma porta USB onde pretendo espetar um HD externo.

Então, o novo modem/roteador chegou ontem e aproveitei o feriado para me estressar com a configuração, brincar com a USB, violar a garantia e tirar uma fotos.

Primeiro uma foto com os dois modems, o novo e o antigo:

Modems

Aqueles padrões na caixa do TP-Link são furos de ventilação. A caixa é bem ventilada, inclusive por baixo:

Modem por baixo

Uma informação importante vem logo abaixo do primeiro código de barras à direita. É a versão de hardware do modem, que precisei quando fui configurar o aparelho. Todas as conexões são feitas na parte traseira:

Conexões do Modem

E por dentro ele é assim:
PCB TD-W8968 TP-Link

A parte ADSL usa um CI RT63087N (não achei o data sheet - lado esquerdo da foto em cima), o CI do roteador é um RT63365E (também sem data sheet - no centro da foto). A parte de RF tem um CI com um dissipador em cima e não dá pra saber qual é. A parte de alimentação conta com dois MC34063.

Para comparação vejam a parte interna do WAG120N:
Linksys WAG120N PCB

Notem que este Linksys também possui duas antenas. A primeira ANT1 é uma antena impressa (lado esquerdo da foto, perto do cabo da outra antena). A segunda é uma anteninha no canto superior direito. Em detalhe:
Antena Interna

Mas voltando ao TP-Link, liguei os cabos de alimentação (fonte externa de 12V x 1A), cabo de rede ao PC e o cabo da linha telefônica. Fui lá no browser e digitei 192.168.1.1 e abriu a tela de configuração. Configurei via setup rápido (no menu tem a opção Oi Velox!) e... Nada dos LED´s do ADSL, Internet e Wi-Fi acenderem. Testei a internet e estava funcionando, só os LED´s que continuavam apagados. O Wi-Fi embora configurado e habilitado não estava "no ar".

Reconfigurei na mão e continuou igual. Retornei as configurações de fábrica pelo browser, reconfigurei na mão e continuou igual. Reset pelo botão externo, reconfigurado na mão e continuou igual. Usei o CD de configuração e... nada. LED´s apagados, internet funcionando via cabo e Wi-Fi morto. Comecei a pensar que havia comprado um aparelho com defeito. Olhei os manuais no site do fabricante e acabei numa página de download de firmwares para o aparelho. Os firmwares variam conforme a versão do hardware e o meu estava na versão 2_131011 e havia uma nova (2_131224). Resolvi arriscar uma atualização, o que seria melhor do que esperar pela troca por outro aparelho.

Então tá, modem atualizado com a última versão, reconfigurei pelo setup rápido e... Funcionou tudo!

Testando o alcance, com a potência do Wi-Fi em 100% (o antigo não tinha configuração de potência de saída), consegui usar em todos os pontos da casa. O compartilhamento de arquivos já está no ar também, embora no momento só espetei um pen drive de 16GB (aquele). Aparelho muito bom, tirando o comportamento estranho antes da atualização. Recomendo.

P.S. - O post está meio fora da ordem dos acontecimentos. A garantia só foi violada depois do equipamento funcionando. ;-)
Related Posts Plugin for WordPress, Blogger...