quarta-feira, 26 de março de 2014

Sobre protoboards...

0 comentários
Tentando arrumar a bagunça aqui acabei separando os meus protoboards (ou matriz de contatos ou breadboard ou pront-o-labor ou outro nome qualquer) e tirei umas fotos pra mostrar pra vocês e contar algumas histórias.

Começando do começo, meu primeiro contato com estas placas foi por volta de 1987-88 vendo minha irmã montando os trabalhos do curso técnico. Alguns anos depois foi a minha vez, na mesma escola e provavelmente com as mesmas placas. Como os "protos" já haviam passado pelas mãos de muitos alunos não era dificil encontrar algum mau contato, furos alargados, plástico derretido e outras falhas. E foi no terceiro ano que meu grupo na feira anual da escola resolveu montar um robô seguidor de trilha. O robô tinha quase um metro de comprimento, era pesado e podia levar uma pessoa em cima (pelo menos nos testes ele aguentou). O circuito de controle estava espalhado por três protoboards daqueles grandes, todo com lógica discreta. Naquela época eu ainda estava começando a aprender Z80. Claro que não funcionou e acabamos não apresentando nada...

Pula alguns anos (1999 e já na faculdade e também numa feira anual) lá estava a Séfora com o seu protoboard montando um circuito de acionador de cargas via telefone (clássico DTMF com MT8870) faltando algumas horas para começar a feira. Ela me pediu ajuda e lá fui eu ajudar a descascar fios e montar o circuito, com o esquema desenhado a mão numa folha de papel toda amassada. Não me lembro quando nem como aconteceu, mas este protoboard acabou aqui em casa e está comigo até hoje. Quem acompanha o blog já deve ter visto ele em algum vídeo ou postagem (é um PL-553):


Ele ainda está com a montagem da fonte de tensão negativa. Este é dos antigos, com a placa de baixo de metal e o nome da empresa que fabricava ainda era Shakomiko. Hoje as placas de baixo são de plástico e a empresa se chama só Shako.

Há uns dois anos ganhei da Séfora (não sei onde ela conseguiu) um destes protos com placa plástica, do modelo PL-551. Retirei a parte de baixo e coloquei numa placa de protótipos da Sure Electronics:


No momento está montado um circuito de testes com a decepcionante placa "Freedom Board" da Freescale (preciso escrever sobre isso). Quando concluir os testes vou montar os componentes, que vieram numa caixa plástica bem legal:

Normalmente uso os protoboards para pequenos testes. Prefiro mais usar placas padrão de fenolite ou fibra de vidro que podem ser cortadas no tamanho apropriado, não apresentam tantos problemas e podem servir até como montagem final.

Ah, lembrei de outra história. Havia um pessoal por aqui na década de 80 e inicio dos 90 que faziam montagens em protoboard sob encomenda. Lembro que era cobrado por conexão, quanto mais fios mais caro ficava. E o pessoal caprichava, com os fios dobrados em angulos de 90 graus, cores combinando e tudo mais. Ficava muito bonito (e funcionava).

Outro protoboard que tenho aqui é este modelo mais recente (PL-554H), também com placa metálica:


Encontrei ele num ferro velho recentemente. Preciso desmontar e dar uma limpada.

E dos ferro velhos da vida veio esta outra aqui, que veio com um circuito montado:

Alguém teve um certo trabalho montando o circuito e fiquei com pena de desmontar. Já pensei várias vezes em fazer isso, mas sempre desisti. Gostei do circuitinho. Ele tem uma EPROM 2716, dois contadores CD4024 e mais dois CIs CD4050, além de um LED laranja. Não sei o que ele faz, mas se desta vez eu realmente desmontar a placa já pensei em dar uma olhada no que está gravado na EPROM. Comprei ela na mesma época em que encontrei aquele arcade MSX (2009).

O curioso deste protoboard é que ele também é uma montagem. São duas placas básicas aparafusadas em cima de uma placa de fenolite cheia de furos com duas cantoneiras de aluminio. Olha a parte de baixo:

segunda-feira, 24 de março de 2014

Pedal de efeitos: Parte final (finalmente!)

0 comentários
Bom, antes tarde do que nunca...

Há três anos montei um pedal de efeitos para guitarras e publiquei o andamento do projeto em cinco partes aqui no blog. Faltou finalizar e postar o código fonte. Era pra ser mais completo e com oito efeitos diferentes, mas engavetei (literalmente) o pedal e só agora recuperei, fiz um vídeo dele funcionando e dei uma conferida no software para ver se estava "publicável". Como estou fazendo uma limpeza nas coisas velhas por aqui e vou ter que dar um fim para o pedal (desmontar) achei melhor publicar os resultados até o ponto que parei. Vai que aparece um maluco que queira continuar ou fazer algo parecido...

Esta versão tem quatro efeitos: delay de aproximadamente 10ms até 250ms, delay até próximo de 800ms, delay de 1ms a 14ms (não é muito útil) e uma versão experimental de reverberação que não ficou muito boa. No vídeo abaixo dá pra ver os efeitos em ação. Como não tenho uma guitarra (e nem sei tocar), usei o Garage Band no iPad para simular a guitarra, com todos os efeitos (do Garage Band) desligados.



E para ficar registrado seguem, novamente, os esquemas do pedal. Primeiro a parte analógica com os amplificadores e filtros de entrada e saída:

Esquema pedal delay
E a parte digital:
Esquema pedal delay

O pedal:


A montagem interna (ninho de gato):

Mais detalhes podem ser encontrados nos posts anteriores:


Agora o software. Lembrando que não é a versão final e que não haverá modificações. Todo o software roda na interrupção do conversor AD. Como o software é pequeno e a memória do microcontrolador é grande (256kB) usei várias tabelas indexadas pelo valor da tensão no potenciômetro que seleciona o valor do delay. Não lembrava que havia feito isso, só agora revisando o código é que vi...

Para baixar o código fonte clique aqui! (Não ligue para a bagunça, o software ainda estava em testes...). Como sempre a licença é WTFPL.

quarta-feira, 19 de março de 2014

Identificando transformadores

0 comentários
Bom pessoal, já falei da minha fonte de bancada nos primórdios do blog e ela me servia bem até hoje. Mas agora vou começar um projetinho com amplificadores operacionais que vai precisar de uma fonte simétrica (+15V e -15V) que minha pobre fonte não consegue fornecer. Assim lá vou eu fazer mais uma fonte, começando por encontrar um transformador com a tensão correta.

E aí começaram os problemas. Primeiro fui nas lojas daqui e nenhuma tinha um transformador de 15V. Eu até poderia comprar direto na fábrica e já estava quase ligando pra lá quando pensei nos transformadores que venho acumulando faz tempo. Estes aqui foram comprados nos ferro velhos ou recuperados de equipamentos que desmontei. Pra que gastar comprando um componente novo se algum destes pode me servir?

Transformadores

Decisão tomada, separei as peças da foto. Um dos grandes será o da nova fonte, os pequenos talvez sirvam para  o circuito final, que terá fonte própria. Faltava descobrir as características dos transformadores. Por serem usados é difícil encontrar algum com marcação. Deste lote só dois vinham devidamente identificados com a tensão de entrada, de saída e as correntes de saída:

Transformadores Identificados

Quando isso não existe eu tento manter os fios com a chave de tensão de entrada. Saber onde é o primário já é um bom começo:

Transformadores com fio
Eu ia descrever aqui todo o meu processo de como identificar transformadores, mas procurei antes de escrever e encontrei um tutorial muito bom e completo do grande Newton C. Braga sobre o assunto, leiam lá. No meu caso eu não uso uma lâmpada série e sim uma tomada com fusível de 1A. Neste lote aqui o fusível não queimou nenhuma vez, mesmo quando liguei dois primários de 110V em paralelo fora de fase (o trafo só esquentou). E um pouco de cuidado para não tomar choque também é recomendável...

A tensão de saída eu medi a vazio (sem carga) mesmo. A determinação de potência é mais crítica, mas dá pra ter uma idéia comparando com um transformador de potência conhecida. Se o trafo desconhecido for muito maior que o de referência a potência é maior (hehe). Ao fim dos testes anotei nas carcaças as medidas de tensão (um deles marquei os fios):
Transformadores Identificados
E como a lei de Murphy é implacável não havia nenhum trafo de 15V. Ou era de 9V ou era de 18V ou tensão maior. Mesmo assim vou me virar com um deles e começar a diminuir a quantidade de coisas guardadas.

segunda-feira, 17 de março de 2014

E meu soprador térmico foi pro saco...

16 comentários
Já falei anteriormente sobre meu hábito de recuperar componentes de placas velhas e que antes eu usava um soprador térmico na desmontagem. Pois então, neste fim de semana (como sempre) resolvi desmontar uma placa de um 3 em 1 que ganhei recentemente. Como a placa mede 32 x 22 cm e tem muitos componentes para retirar pensei que seria melhor tentar consertar o soprador térmico para agilizar a coisa. A placa é esta aqui:


Como eu usava pouco o soprador ele estava emprestado para a Séfora quando ocorreu o problema e, segundo ela, aconteceu o seguinte: Ela estava preparando um leitão à pururuca e o soprador fez um barulho estranho e começou a soltar um cheiro de queimado (o soprador, não o leitão). Pra quem achou estranho o uso do aparelho, saibam que funciona. Primeiro se assa o leitão e depois de assado se passa o soprador térmico em cima pra torrar a pele.

Mas voltando ao soprador, ele ficou guardado até agora (um ano mais ou menos). Pra desmontar a já citada placa peguei o soprador novamente e liguei pra ver se ele dava sinal de vida. Realmente a descrição estava correta, ele fazia um barulho estranho e cheirava a fio queimado. Na boca não havia sinal de fluxo de ar. O soprador é um TA-1050 da Toyo:

Comprei ele numa reciclagem que já não existe mais e ficava num galpão fechado do outro lado da cidade. Só fui lá uma vez só, mas foi uma das "visitas ao ferro-velho" mais legais que já fiz (teve até uma escalada numa "montanha" gigantesca - quase três metros de altura e uns dez de largura - de multímetros (!)). Mas voltando ao soprador...

Depois de aberto descobri que o problema era na hélice do ventilador, ela é feita de acrílico (acho) e quebrou bem no centro que vai encaixado no eixo do motor:



O barulho então era por causa da parte que ficou no eixo que batia na hélice, que ficou solta. E claro, sem a hélice girando não havia fluxo de ar. Sem o fluxo de ar a resistência aquecia demais e por isso o cheiro de queimado. E como consertar isso? Bom, aí é que está o problema. Até tentei colar com super bonder:


Mas não teve jeito, a hélice soltou novamente ao girar. Mesmo com uma cola mais forte a hélice não será mais a mesma. Ela não ficará perfeitamente centralizada e poderá quebrar novamente com o tempo. A não ser que eu encontre outra hélice completa e em perfeito estado, o que eu acho improvável, este soprador foi pr'o saco... Pr'o saco das coisas que talvez, um dia, serão consertadas.

quinta-feira, 13 de março de 2014

Por dentro da fonte Philips PW4620 (fonte de alta tensão e ratemeter)

1 comentários
Ganhei esta fonte de um colega já faz algum tempo (ela foi o assunto do meu primeiro vídeo log) e agora resolvi tirar umas fotos do que tem dentro para registro. Interessante é que não há muitas referências a este modelo na Web, somente citações de que usaram em algum experimento (e, claro, o meu vídeo).

Trata-se de uma fonte de alta tensão variável (0 a 2,5 kV) e, até onde entendi pesquisando por aí, ela serve para alimentar válvulas detectoras de radiação e medir os níveis (o tal do "ratemeter" do nome) de emissão (em um tal de "cps" que deve ser alguma coisa por segundo). Nada espetacular, apenas emissões fracas em laboratório. Pelo tipo de montagem e pelos componentes eu chuto que a Philips talvez a produziu no início da década de 70.

Esta aqui já não funciona mais e ainda estou pensando o que fazer com ela. Talvez eu a desmonte para reaproveitar alguma coisa. Meu colega ia levar para o centro de reciclagem mas, por sorte, me ofereceu antes.

Mas vamos as fotos:
High Voltage Power Supply Ratemeter Philips PW4620
O painel frontal
PW4620
Detalhe do painel do medidor
PW4620 painel traseiro
Painel traseiro
PW4620
Placa de identificação
A montagem interna é feita em slots, com 12 placas encaixadas na vertical. A caixa de metal com o desenho de um raio é a parte de alta tensão. A caixa azul acredito que seja o transformador de alimentação, que talvez seja toroidal:
PW4620

Quatro capacitores amarrados ao painel frontal, logo acima das chaves de teclas:
PW4620

Depois das placas retiradas dá pra ver os conectores de encaixe. A HP costumava usar esse tipo de montagem em seus instrumentos por volta da década de 60 e 70:
PW4620

Vista da parte de alta tensão com a blindagem retirada:
PW4620

O transformador de alta tensão fica embaixo da placa mostrada acima. A corrente é baixa e a frequência deve ser um pouco alta, já que o transformador não é tão grande e usa núcleo de ferrite.
PW4620

Esquema de ligação do transformador de alimentação. Todo o equipamento possui marcas de fuligem:
PW4620

A fiação por baixo dos conectores, toda amarradinha:
PW4620

Vista de baixo do transformador de alimentação e a placa da fonte:
PW4620

E para ficar registrado, uma foto de cada placa do equipamento. Primeiro uma das placas da fonte de alta tensão. As placas deste setor estão com aparência melhor que as outras por ficarem protegidas pela caixa de metal de blindagem/proteção. Os componentes azuis ligados em série são resistores RN65C  (padrão militar) de precisão (1%) de 1M Ohm:
PW4620 PCB 1
E a outra placa da fonte de alta tensão:
PW4620 PCB 2

Na placa acima ainda vai um conector onde fica a placa abaixo, com quatro diodos BY184 em série:
PW4620 PCB 2b

Agora as placas que ficam fora da blindagem. A primeira eu não limpei antes de tirar a foto, para mostrar o quanto de poeira foi acumulado. Aqueles dois resitores de potência na parte de baixo parecem modernos demais e devem ter sido colocados em alguma manutenção:
PW4620 PCB 3

Nesta outra placa da pra ver um capacitor de poliéster "zebrinha" descascando. Praticamente todos os capacitores deste tipo na fonte estão com o mesmo problema:
PW4620 PCB 4

Uma placa só com capacitores, provavelmente da parte do ratemeter, já que ela fica próxima a chave de "Range C.P.S" do painel frontal. E todos aqueles capacitores amarelos são de precisão (1%), algo raro de se ver a não ser em equipamentos de medição. Ainda tenho que procurar nos meus alfarrábios por uma tabela para poder ler o valor daqueles capacitores tubulares na parte inferior direita:
PW4620 PCB 5

Esta aqui tem um CI FCJ111 (Flip-Flop JK):
PW4620 PCB 6
E mais um CI nesta aqui, um TTL SN7490 (contador):
PW4620 PCB 7

E tudo discreto nesta outra, nada menos que 17 transistores:
PW4620 PCB 8

Mais uma discreta e com uma marca de aquecimento. Parece que 4 transistores metálicos foram trocados por equivalentes em encapsulamento TO-92 (BC557). Aquela ponta de papel logo acima da placa é parte de um bilhete colado na parte de baixo.
PW4620 PCB 9

O bilhete diz o seguinte: "Retirado dois transistores 2N2484 para o equipamento de difração de Carborundum". Parece que a fonte virou fornecedora de peças para outros equipamentos.
PW4620 PCB ?

E as fotos das três últimas placas, todas discretas:
PW4620 PCB 10

PW4620 PCB 11

PW4620 PCB 12

terça-feira, 11 de março de 2014

A irritante busca "esperta" de alguns sites...

2 comentários
Bom, meu primeiro post de reclamação (eu acho que é, não tô a fim de ver todos os posts anteriores). Vamos lá...

Caso ainda não saibam, além de eletrônica meu outro hobby é colecionar (ou amontoar, segundo alguns familiares) gibis. E neste fim de semana resolvi procurar alguns albuns da série "Bone" do Jeff Smith para completar a coleção e no Mercado Livre me deparo com isso:


E notem que não existe a opção (visível) de procurar em outras categorias de produtos. Já me deparei com este problema antes, mas só agora fiquei irritado (eu não gosto de chapéus e bonés). A solução que uso é buscar algo que caia na categoria que quero e depois marcar a opção "somente em Categoria X", lá na caixa de busca (ou melhorar a busca com alguma palavra a mais). Para entender melhor, tente buscar algum ano no Mercado Livre: sempre cai na categoria de carros. Pode ser o que a maioria procura, mas não é o meu caso...

É chato um site querer adivinhar o que você está pensando e não dar ao menos uma opção de você dizer a ele que não era bem isso o que você queria. E o pior é que isso ocorre em outros sites, testei procurar por "Bone" no Buscapé, BondFaro e ShoppingUol e só me mostraram bonés. O Buscapé até oferece a opção de procurar em outras categorias, mas tem que prestar atenção pra achar. Legal foi o Jacotei que mostrou a categoria "Bonecas". Ele também apresentou uma opção para procurar em outras categorias, mas em letras pequenas no canto da tela.

Outra coisa irritante e que está pipocando por aí são os apps de sites para celulares e tablets. Eu uso muito o iPad para navegação e em muitas páginas que visito aparece um aviso para instalar o app do site. Separei dois exemplos aqui, sendo o primeiro o site da NXP que carrega a página e logo em seguida sobrepõe com uma tela assim:


E é comum também em fóruns:


Qual a vantagem de instalar um app de um site se a grande maioria tem muito menos funcionalidades que a página? O app irá ocupar espaço na memória, irá ajudar a atulhar ainda mais de ícones a tela e será esquecido rapidamente. Jogar uma propaganda na minha cara não vai me fazer mudar de idéia...

terça-feira, 4 de março de 2014

Conversor RMS-DC para o Multímetro

2 comentários
Aproveitando o feriado de carnaval, montei um conversor para medir tensão AC RMS com meus multímetros digitais:

Conversor RMS DC
O painel ainda precisa ser desmontado para colocar as legendas do painel feitas no PC (como o aparelho de baixo). Por enquanto ficam as que fiz com caneta mesmo.

O circuito é o seguinte:

Esquema conversor RMS DC

Nada demais aí, apenas juntei duas idéias do manual do AD736: Um circuito atenuador de alta impedância (figura 25 do manual) e o circuito alimentado por uma bateria de 9V (figura 28 do manual). Para o atenuador usei os resistores que retirei do medidor valvulado do post anterior. Tive que associar os resistores de forma a conseguir os valores certos (900k, 90k, 9k e 1k). Com os valores mostrados a impedância de entrada fica em 1M, mas seguindo o esquema do manual dá pra conseguir 10M.

Como o CI AD736 vem calibrado de fábrica para 0,3% (típica) e os resistores do atenuador são de 0,5% de tolerância a precisão fica melhor que 1% (para onda senoidal) até 1kHz aproximadamente, ou uns 2% até uns 10kHz (o manual diz 33kHz com 200mV na entrada, mas só testei até 10kHz). Para precisão melhor recomendo trocar o AD736 por um LTC1968 que vai até 150kHz  (com erro de 0,1%). Sem esquecer de contar, no final, com a precisão do multímetro também (Meu Icel tem 0,5% de precisão na escala de 200mV).

Meu circuito foi pensado para medir a potência de saída de amplificadores de áudio, em uma carga de 4 ou 8 Ohms. Com o valor da tensão da saída é só usar a fórmula: P = V^2/Zout pra achar a potência. Para medir valores AC RMS + componente DC os capacitores C1 e C5 devem ser retirados do circuito com um "curto" no lugar. Por falar em C1, usei um superdimensionado (para 1600V), mas poderia ser um para 500V. O manual não especifica qual o tipo de capacitores usar no conversor, mas normalmente se usa capacitores de Tântalo. Como só tinha capacitores SMD deste tipo e de 10uF x 16V tive que fazer uma associação de três para conseguir os 30uF necessários. Eles foram montados na parte de baixo da placa:

Capacitores de Tântalo SMD

Lembrando que o conversor AD736 possui maior precisão em frequências entre 50Hz e 1000Hz. Fora dessa faixa a precisão vai caindo. Além disso o "crest factor" (valor de pico/valor RMS) da forma de onda degrada ainda mais esta precisão. Normalmente os multímetros com o tal de "True RMS" informam essa degradação lá nas letrinhas miúdas do manual (isso quando informam) e muita gente nem sabe da existência desse erro.

Para testar o funcionamento liguei o aparelho no meu multímetro (ICEL MD-6111) na escala de 200mV e como fonte de tensão AC usei meu celular com o app "Waveform Generator Demo":

Conversor RMS para DC - Testes

Para comparação liguei também meu osciloscópio digital com a medida de tensão RMS ativada. As medidas bateram até o limite superior de frequência do app, com um erro bem pequeno. O ideal seria usar um fonte AC de precisão, mas não é tão fácil conseguir uma. Algo que preciso colocar é um LED no painel para indicar quando o aparelho está ligado. Do jeito que está eu esqueci ele ligado e só fui perceber no outro dia.

E pra finalizar, dei uma pesquisada na web pra ver se alguém já tinha feito algo semelhante e encontrei o do Richard Cappels que usa um AD737 (um AD736 sem o buffer na saída).
Related Posts Plugin for WordPress, Blogger...