quinta-feira, 28 de novembro de 2013

Construindo uma antena interna para TV (Versão 2)

3 comentários
Depois de montar uma antena interna para uma das TVs aqui de casa fui cobrado para construir mais uma para outra TV. Esta TV estava parada já há algum tempo por não pegar quase nenhum sinal. A antena usada neste caso era uma telescópica com um lado quebrado ligada via uma fita de 300 Ohms e um balum para 75 Ohms. Ela ficava jogada num canto atrás da TV.

Resolvi montar outra dipolo de meia-onda mesmo, por ser mais simples e por uma questão prática: Como os elementos são fixos o usuário não tem muito o que mexer na antena, ela fica paradinha sem risco de romper os cabos ou quebrar os elementos. O material para a montagem era a própria antena telescópica da TV e um cabo de 75 Ohms destes que vinham com video cassete:

Antena interna e cabo coaxial

Retirei todos os tubos da antena (só puxar forte que eles saem fora):
Elementos da antena

Para o cálculo do tamanho dos elementos levei em conta que esta TV será usada mais para assistir aos canais 16 (EPTV Sul de Minas/Globo) e o 14 (TV Alterosa/SBT). Assim uma antena para o canal 15, no centro dos dois canais, seria o ideal. Consultanto a tabela de frequências de canais, o canal 15 tem a frequência central em 479MHz. O que dá um comprimento de onda de 62cm e o dipolo terá então um comprimento total de 31cm ou 15,5cm por elemento.

Com o comprimento calculado, peguei os tubos da antena e cortei no tamanho adequado:
Elementos cortados

O suporte de plástico original da antena também foi aproveitado. No original a fita de 300 Ohms é ligada diretamento aos elementos, causando descasamento e perdas (o dipolo tem resistência de 73 Ohms). Aqui da pra ver a fita original:
Suporte da antena

Colocando o cabo de 75 Ohms o casamento fica um pouco melhor, mas foi preciso cortar um pedaço do suporte para que este cabo entrasse:
Suporte da antena cortado

Por fim soldei o cabo no suporte e aparafusei os elementos:
Antena montada

Com o medidor de nível de sinal procurei o melhor ponto para a antena, nos canais 14 e 16, eliminando o tipico "mexe na antena e vê se a imagem tá boa". Com o melhor nível medido, fixei a antena no lugar (na lateral de um guarda roupas) e liguei na TV pra comprovar o funcionamento. Funcionou como esperado.

quarta-feira, 27 de novembro de 2013

Som do PC: Montando as Caixas de Som Makizou (Parte 4)

0 comentários
Continuando a saga do som do PC, finalmente fechei as caixas de som. É claro que antes eu tinha que tirar algumas fotos, pois nunca mais verei suas "entranhas":

Caixas de som Makizou por dentro

É estranho como a cola branca mancha o MDF, e o efeito piora com o flash da câmera. Falta os sacos de pedras no fundo (segundo a "receita" japonesa), que vão entre os dois nichos na parte de baixo. Fiz um teste e vi que dá pra colocar com a caixa fechada.

Estava em dúvida sobre como ficaria a parte interna, mas acabei pintando de preto fosco (com tinta spray) as partes que vão aparecer. O resto nunca mais verá a luz do dia (se ninguém quebrar as caixas). Se no final eu não gostar do resultado dá pra colocar uma tela com tecido ortofônico. Olha as duas com a tinta secando:

Pintura das caixas Makizou

A fita crepe não é tão necessária assim, dá pra colar sem problemas por cima da tinta. As duas tampas também foram pintadas apenas o necessário:

Tampas das caixas de som

E depois da tinta secar, colei as tampas nas duas caixas e aparafusei em alguns pontos. Novamente nada de grampos, só o peso das caixas de revistas:
Caixa de som fechada
Agora só falta colocar os alto falantes e testar. Acho que no final de semana já vai dar pra brincar de fazer barulho.

terça-feira, 26 de novembro de 2013

E o meu medidor de nível de RF foi pro saco...

4 comentários
Já falei deste aparelho no último Vlog, então vou pular os detalhes do funcionamento e de seu circuito.

Encontrei este medidor de nível de RF (TV/FM Level Meter MC-160N da Promax) num ferro velho e ele funcionava até que bem (só quando alimentado pelo suporte de pilhas):

TV/FM Level Meter MC-160N Promax

A foto foi tirada quando fiz o primeiro teste com ele. Depois disso liguei algumas vezes pra ouvir uma ou outra emissora de FM e uma última vez para gravar o video log. Ele já estava parado há mais de um mês, até que finalmente precisei usá-lo de verdade.

Normalmente este aparelho é usado para alinhar antenas de TV e era essa a minha intenção. Uma das TV´s aqui de casa estava há muito tempo parada por falta de uma boa antena. Claro que eu fui lá montar uma anteninha dipolo de meia onda e aproveitar para testa-la com o medidor para encontrar o melhor ponto de recepção. Falarei sobre esta antena num próximo post.

O problema (na verdade uma manifestação da lei de Murphy) foi que depois da antena contruída e pronta para o teste o medidor pifou. Ele ligava, apresentava o som de estática no alto falante, mas não pegava nada. Girando o potenciometro de sintonia o frequêncimetro só mostrava a mesma frequência (bem alta, na casa de 1.4 GHz). 

Abri o aparelho e comecei a procurar o problema, que acabou sendo a falta da tensão de 30V para o sintonizador de canais (é um sintonizador de TV mesmo, conhecido por aqui como "Varicap"). Esta tensão vai para o potênciometro de sintonia e é gerada por um CI 555 chaveando um transformador. O trafinho pode ser visto na foto abaixo, no canto inferior direito:
TV/FM Level Meter PCB
O 555 está por baixo da placa (encapsulamento SMD). O CI está em sua tipica configuração de oscilador, mas não havia sinal algum na saída (pino 3). Troquei o CI e o problema continuou. Tentei entender o circuito e notei alguns transistores nos pinos 4 e 5 do 555. Fucei, fucei e nada. E nessa brincadeira algumas trilhas descolaram e resolvi parar antes que piorasse a situação. Se ao menos eu tivesse o esquema...

Um teste rápido para ver se o problema era só a falta dos 30V seria conectar uma fonte externa ao potenciometro de sintonia. O problema é que minha fonte de bancada só vai até 15V. Sem muitas opções resolvi montar um circuitinho rápido para gerar os 30V a partir da tensão de 9V de alimentação do aparelho. Peguei um CI MC34063 e montei o seguinte circuito:
Esquema fonte 30V
Os únicos valores criticos de componentes foram os de R3, R4 e R5 onde usei resistores de 1%, para acertar o valor de 30V na saída. A bobina L1 eu peguei algumas recuperadas de sucata e fui testando mais pelo tamanho do que pelo valor. Foi montar e funcionar:

Placa fonte 30V

A saída foi ligada a um dos extremos do potenciometro enquanto o outro foi aterrado:
Placa fonte 30V

Testei e o aparelho voltou a funcionar, sintonizando e correndo as faixas normalmente. E foi com esta adaptação que consegui terminar o trabalho da antena. Deixei o circuitinho lá dentro até, quem sabe, eu encontrar o esquema.

Pra finalizar, uma foto da placa do frequencímetro, com um único CI:
Placa do frequencimetro

segunda-feira, 25 de novembro de 2013

Consertando um Carregador de Celular

1 comentários
Ok, não foi bem um conserto eletrônico, mas vamos lá...

Neste fim de semana a Dona Esposa derrubou o carregador do celular no chão, quebrando os encaixes que fecham a caixa e o lugar onde prende o plug da tomada. Dá pra usar outro carregador, ou qualquer outra coisa com saída USB (desde que consiga fornecer corrente suficiente), pra carregar o celular. Até pensei nisso, mas como o dano não foi tão grande acabei consertando o aparelho.

As peças ficaram assim:

Carregador de Celular quebrado

O problema maior era no pino onde vai um parafuso que segura o mecanismo retrátil da tomada:

Carregador de Celular Quebrado

Antes de consertar o carregador dei uma olhada no circuito. Apenas dois transistores formam o oscilador com o transformador. O loop é fechado por um diodo zener e isolado com um opto-acoplador. Este circuito é bem comum nos carregadores Xing-Ling. A entrada de rede é "básica" (pra não falar coisa pior), com um único diodo retificador (meia onda) e um capacitor eletrolitico de 2,2uF x 400V. Sem filtros e proteções de entrada. Um dos LEDs indica que o carregador está ligado e o outro quando o celular está conectado. Ele não indica quando a bateria termina a carga.

Placa do carregador de celular

Por baixo da placa não tem nada:
PCB do carregador de celular

O conserto do carregador foi simples, algumas gotas de Super Bonder fixaram as peças plásticas no lugar. Um parafuso com um diametro um pouco maior deu conta de fixar o plug:

Carregador consertado

segunda-feira, 18 de novembro de 2013

Som do PC: Montando as Caixas de Som Makizou (Parte 3)

5 comentários
Aproveitando o feriado coloquei os conectores, a fiação e colei a parte traseira (as que eu pintei, do post anterior) em uma das laterais.

Começando com os conectores. Acabei não encontrando os plugs bananas fêmeas no tamanho que eu queria. Na verdade não encontrei nenhum plug nas lojas daqui. Tive que usar alguns que eu comprei na China, dos mais baratos:


Não ficou tão ruim assim. E como os conectores são mais curtos, tive que fazer uma adaptação para poder aparafusar os conectores:


Pra facilitar a montagem estou colocando parafusos pra madeira em alguns pontos. Isso ajuda muito na hora de colar:


A sujeira na parte pintada é do pó de MDF devido as furações e das peças lixadas. E essa mesa não está lá muito limpa também. Vou limpar no acabamento final...

Aproveitei e coloquei a outra lateral pra ver como a caixa deve ficar:


Apenas a lateral de baixo está colando e aparafusada, a de cima só encostada. A entrada frontal da caixa ficou assim:


As manchas são da cola, que ficam com essa aparência feia no MDF. Elas parecem pior com o flash da camera. Dá pra ver também a cola branca que eu havia acabado de colocar. Estou montando a segunda caixa do par ao mesmo tempo, mas no chão:


O próximo passo (após secar a cola desta semana) será fechar definitivamente a caixa. Pra isso preciso decidir se vou deixar no MDF cru ou se vou pintar ou ainda se vou colocar algum revestimento externo. Mas já vai dar pra colocar os alto falantes e testar. Tenho inclusive uma idéia de como fazer um teste comparativo pra ver se elas são melhores que o som atual do PC.

terça-feira, 12 de novembro de 2013

Som do PC: Montando as Caixas Makizou (Parte 2)

2 comentários
E Domingo passado resolvi fazer um teste de pintura nas Makizou. Minha idéia era pintar as caixas com tinta spray preta fosca. Fiz só um teste nas peças traseiras das caixas, pra ver se ficaria bom. Protegi as laterais com fita crepe pra não pegar tinta (onde vou colar nas laterais das caixas):

Pintando as caixas de som

Os dois furos embaixo de cada peça são para os plugs banana. A foto foi tirada logo depois da pintura, agora está um pouco melhor, mas não gostei do resultado. Ainda não sei se pintarei as caixas com essa tinta ou se colocarei algum revestimento (como folha de madeira). Estou aceitando sugestões...

Coloquei também a espuma logo abaixo do furo do alto falante, parecida com a que vi em um site japones onde o cara descreve a montagem de um kit comprado direto da Makizou. Aqui cabe explicar que Makizou é o nome do fabricante de kits de caixas de som e não o modelo das caixas (esta que estou montando é o kit M-8BH). A foto não ficou muito boa, tirada de um angulo não muito favoravel (não queria mexer na caixa que estava colando):

Revestimento das caixas de som

Devo concluir as caixas (sem o acabamento externo) nas próximas duas semanas, se tudo der certo. Algo que pode atrasar a montagem são os plugs banana que ainda não consegui encontrar aqui na cidade. A loja que normalmente compro componentes não tinha nenhum em estoque e a outra fecha para o almoço no único horário que eu posso ir até lá. Até tenho uns plugs banana aqui, mas são curtos demais (as paredes das caixas tem 15mm de espessura).

E pra terminar, vejam o que dá comprar ferramente ruim:

Grampo quebrado

Este é um dos grampos que comprei pra prender as peças enquanto colavam. Isso foi bem no começo da montagem, coloquei o grampo quase no limite da abertura e alguns segundos depois ele estourou! O pedaço que quebrou voou longe. Depois do ocorrido passei a usar "pesos" (caixas cheias de revistas) em cima das peças:
Colando as caixas de som

sexta-feira, 8 de novembro de 2013

Som do PC: Mais Fonte Chaveada de Alta Tensão

0 comentários

Opa, parece que encontrei o culpado do liga-desliga da fonte: O transformador!

Hoje pensei melhor sobre o problema e depois de ler o datasheet do TOP247YN descobri que ele tem proteção contra curto circuito e loop aberto. Nestes dois casos o CI monitora a largura de pulso e desliga caso este ultrapasse um limite. O valor máximo da largura de pulso é de 78% (valor tipico). Como estou fazendo os testes com entrada em 127Vac de entrada e a fonte foi projetada (no software) para funcionar até 230Vac ela está no pior caso onde a largura de pulso é maior. Assim, caso ela estivesse perto do limite da largura de pulso o CI iria desligar as saídas (não desliga completamente, ele joga para 4% de largura de pulso).

Para testar esta hipótese (o CI estar no limite da largura de pulso máxima), fiz alguns testes e obtive as seguintes medidas, tomadas no secundário de baixa tensão, antes do diodo retificador.

1. Saída de 6,3V com carga de 3R e saída de alta tensão com um resistor bleeder de 180k (só pra descarregar os capacitores de alta tensão ao desligar a fonte):


Largura de pulso na saída

Bom, o problema é esse mesmo: O duty cycle (largura de pulso) está em 76%, quase no limite dado no manual.

2. Agora com carga máxima de 1,5R (4,2A):

Largura de pulso na saída

A coisa piorou, mas a fonte ainda funciona. Largura de pulso em 79%, acima do máximo do manual, mas ela sempre parte. A tensão de saída cai para 6V.

3. Saída de 6,3V com 3R e saída de alta tensão com 10k:

Largura de pulso na saída

Neste caso a fonte demora um pouco a partir. Acho que por causa dos "resistores de fio" feitos de resistência de chuveiro que aumentam de valor ao esquentar. Mesmo assim a largura de pulso já passou do ponto critico, chegando a 84%.

O remédio para isso é um só: enrolar outro transformador com mais espiras no secundário de baixa tensão (6,3V), onde o loop é fechado. Com mais espiras a tensão será maior fazendo com que o CI tenha que reduzir a largura de pulso para compensar. Acho que o melhor ponto da largura de pulso seria em torno de uns 60% com carga máxima nas duas saídas.

quinta-feira, 7 de novembro de 2013

Som do PC: Ainda a Fonte Chaveada de Alta Tensão

0 comentários
Bom, como eu disse no post de ontem estou fazendo os testes com carga na fonte. Faço estes testes com resistores de potência montados numa placa de eucatex com terminais conhecidos por aqui como "proto-bixo", por serem usados no primeiro ano do curso técnico. Não liguem pra bagunça (acho que essa parte não precisava ser mostrada, hehe):


Os resistores verdes formam a carga para a saída de alta tensão. São 10 resistores de 1k Ohm por 7W cada. No momento estão ligados em série (10k x 70W) e podem ser conectados rapidamente para 2,5k, mudando duas conexões. Neste último caso a corrente seria de aproximadamente 100mA.


Logo abaixo, na mesma placa, coloquei dois pedaços de resistência de chuveiro cortadas para dar 3 Ohms cada. Assim consigo testar em meia carga (1 resistência) ou em carga total com as duas em paralelo, o que dá 4,2A. Estas resistências esquentam muito (26W), por isso tenho que usar um ventilador próximo a elas.


O problema que estou tendo, e que já contei ontem, é que ao ligar a carga na saída de alta tensão a fonte começa o liga-desliga caracteristico das proteções do CI TOP247YN. O outro componente que poderia causar o desligamento seria o diodo TVS no primário, mas já foi devidamente "Muntzado" sobrando o CI mesmo. Talvez o trafo? quem sabe...

Um teste que fiz hoje foi colocar a saída de 6,3V a meia carga e ligar a carga de 10k na saída de alta tensão. A fonte ficou no liga desliga por um tempo e depois ligou, mas com 210V aproximadamente na saída. Com a saída de 6,3V sem carga a fonte parte, mas como a largura de pulso fica muito baixa (o loop é fechado no 6,3V) a alta tensão não fica tão alta assim.

Uma olhada na forma de onda no "dreno" do CI TOP247YN daria muito mais detalhes sobre qual seria a causa do problema. Infelizmente não posso fazer isso, pois o meu osciloscópio não é isolado (o terra da ponta de prova é o terra da alimentação) e mesmo se eu colocar um transformador isolador as entradas do scope não suportam mais do que 400V:


Estou usando uma ponta x10 que suporta até 600V para ver as formas de onda na saída de alta tensão. O osciloscópio fica apitando quando uso essa ponta com tensões maiores que 250V. Talvez a ponta (Xingling) não seja tão boa assim. Preciso ver isso também, não quero perder um osciloscópio por causa das pontas ruins...

Então pessoal, este é o estado atual do projeto da fonte. Ligo ela um pouquinho quase todo dia (ou uma vez por semana, por mês), testo aqui e ali, faço umas medidas e espero que em breve ela esteja funcionando 100%.

quarta-feira, 6 de novembro de 2013

Som do PC: A Fonte Chaveada de Alta Tensão

5 comentários
Continuando o assunto do novo som para meu PC, vamos ver como anda a fonte do amplificador valvulado que pretendo montar.

1. O projeto original do amplificador (de 1956) usa um transformador "comum" (pra valvulas) de 60Hz. Como eu queria fazer algo diferente, resolvi fazer uma fonte chaveada para substituir a fonte original. Muita coisa mudou desde que projetei uma fonte destas (uns 15 anos), então procurei algo mais moderno e acabei encontrando os CIs da Power Integrations e seu maravilhoso software PI Expert 9 que entrega todo o projeto calculado e quase pronto pra montar.

2. Infelizmente apesar de ser um software excelente ele não faz cálculos para fontes com saídas maiores que 100V. Como solução fiz um projetinho com 3 saídas em 90V, para poder ver o número de espiras do transformador. Somando os três enrolamentos a saída daria os 270V necessários para o amplificador. O esquema inicial gerado pelo programa ficou assim:
Esquema fonte chaveada de alta tensão

Junto com este esquema o software também gerou a lista de peças e os dados para construção do transformador (com desenhos e tudo).

3. Com a lista de peças fui até o site da Farnell e comprei o material que não tinha aqui ou que seria mais critico na fonte. Isso inclui os eletroliticos que precisam ser especificos para fontes trabalhando nessa frequencia (capacitores com baixa ESR). A Farnell cobra caro, mas fornece os componentes com o part number correto de acordo com os datasheets. E por sorte eles também tinham os núcleos de ferrite e os carreteis que eu precisava:
Nucleos de ferrite

4. A placa de testes (nunca se acerta uma PCB de primeira) foi feita no idoso, mas confiável, Tango PCB:
Placa da fonte no Tango PCB

5. E, acreditem ou não, esta foi a primeira placa que fiz pelo processo de impressão a laser em folha de revista e passada a ferro quente.

Placa virgem e layout impresso
E sim, tive que fazer duas placas, a primeira eu não espelhei o desenho antes de imprimir (podem rir)...

6. Como é um projeto particular e só uma unidade será montada, exagerei nos componentes, com uma boa margem nas especificações para evitar problemas. A placa também ficou bem espaçosa, poderia ter ficado bem menor. Olha ela montada, mas ainda sem o transformador:

Fonte montada sem o transformador

7.  Ah, o transformador... A regra para projetos de fontes chaveadas é que o transformador precisará ser enrolado várias vezes até chegar na versão final. Até agora enrolei dois, sendo que o último tive que tirar do circuito para acertar os enrolamentos duas vezes. Fora os acertos no entreferro (Gap).

8. Comprei uma fita para transformador na China e enquanto ela não chegava tentei montar o primeiro transformador com fita isolante comum. Como a fita é muito grossa acabou que o núcleo de ferrite não entrou. O primeiro trafo ficou só no carretel mesmo:

Primeiro transformador

9. Quando a fita chegou enrolei o segundo trafo:
Segundo transformador

As presilhas plásticas estão aí para manter os núcleos fechados. Fiz isso pois já sabia que ia ter que ficar acertando o trafo depois. Quando o transformador estiver correto ele será definitivamente fechado e envernizado.

10. Claro que a fonte não ia funcionar de primeira. Já estava esperando até explodir alguma coisa na minha cara. Mas até que não foi ruim, a fonte ficou ligando e desligando. Como o trafo foi enrolado a mão ele seria o primeiro suspeito. Tirei do circuito e conferi o sentido (fase) dos enrolamentos e constatei um erro em uma das fases do primário (estava invertido). Assim um enrolamento "empurrava" o fluxo pra um lado e o outro para o outro lado (só lembrar da regra da mão direita). Não ia funcionar mesmo...

11. Corrigido a fase do primário a fonte funcionou. Bom, pelo menos com uma carga leve nas saídas. A saída de alta tensão chegou a perigosos 440V (coloquei capacitores de 450V ali). Retirei umas 20 espiras do secundário para baixar esta tensão. Com carga baixa as tensões ficaram assim:
Fonte funcionando

12. A saída de 6,3V ficou perfeita (o loop é fechado nela) e consegui os 4A nominais. No momento estou brigando com a saída de alta tensão. Tentei puxar uma corrente de uns 30mA (com um resistor de 10k na saída) e ela fica ligando e desligando. Me parece que o CI está protegendo de alguma coisa. Mas ainda não sei o que é e tenho que continuar os testes. Será a tensão do secundário refletida no primário? Temperatura? (pouco provavel, não notei nada esquentando)...

terça-feira, 5 de novembro de 2013

Antenas do Farol de Santa Marta (Laguna S.C.)

0 comentários
Estava olhando umas fotos "antigas" (de Julho de 2011) e acabei relembrando de umas fotos que tirei das Antenas do Farol de Santa Marta em Laguna (Santa Catarina). Como fotos de antenas não servem pra muita coisa numa pasta com fotos de férias movi para outra pasta, no diretório de "imagens técnicas". E como sei que esta pasta provavelmente vai ficar esquecida por lá pensei que seria melhor publicar aqui no blog (vai que tem alguém que gosta de fotos de antenas).

Farol de Santa Marta - Antenas
Clica que aumenta
Procurei mais informações sobre o Farol e segundo a Wikipedia o farol ainda funciona (não sei se funciona, era dia quando fui até lá) e tem distância focal de 1330mm (parece que é a maior do Brasil). E segundo a "Lista de Auxílios Rádio" o rádio farol de Santa Marta tem as seguintes características:

2690. Santa Marta (SW)
Lat. 28°36’.27 S Long. 048° 48’.84 W
Frequência: 310 kHz. Emissão: A2A. Potência: 0,2 kW.
Alcance: 300 M.
Característica do sinal: SW (... .— —), com intervalo de 7,5 segundos.
Equipado com DGPS.

Pensei que a potência fosse maior para essa frequência ("só" 200W). Acho que a antena é esta aqui:

Farol de Santa Marta - Antenas

Tem outra menor lá atrás. Lembro que tinha um abrigo junto a antena com uma placa de "Perigo - Alta Tensão" na porta. Infelizmente não tirei foto do abrigo, vou ver se tiro uma da próxima vez.

Além disso existe uma estação de RACON (RAdar beaCON):
3956. Farol Santa Marta
Lat. 28° 36,23′ S Long. 048° 48,76′ W
Característica do sinal: Z ( — —.. ).
Bandas: S e X. Alcance: 25M.

Como usa banda X (9 GHz) e S (3 GHz) as antenas são bem menores. Procurando nas fotos da pra ver outras antenas que devem ser desta estação:

Farol de Santa Marta - Antenas

Farol de Santa Marta - Antenas
Olha eu aí...
Farol de Santa Marta - Antenas

Related Posts Plugin for WordPress, Blogger...