quarta-feira, 6 de novembro de 2013

Som do PC: A Fonte Chaveada de Alta Tensão

Continuando o assunto do novo som para meu PC, vamos ver como anda a fonte do amplificador valvulado que pretendo montar.

1. O projeto original do amplificador (de 1956) usa um transformador "comum" (pra valvulas) de 60Hz. Como eu queria fazer algo diferente, resolvi fazer uma fonte chaveada para substituir a fonte original. Muita coisa mudou desde que projetei uma fonte destas (uns 15 anos), então procurei algo mais moderno e acabei encontrando os CIs da Power Integrations e seu maravilhoso software PI Expert 9 que entrega todo o projeto calculado e quase pronto pra montar.

2. Infelizmente apesar de ser um software excelente ele não faz cálculos para fontes com saídas maiores que 100V. Como solução fiz um projetinho com 3 saídas em 90V, para poder ver o número de espiras do transformador. Somando os três enrolamentos a saída daria os 270V necessários para o amplificador. O esquema inicial gerado pelo programa ficou assim:
Esquema fonte chaveada de alta tensão

Junto com este esquema o software também gerou a lista de peças e os dados para construção do transformador (com desenhos e tudo).

3. Com a lista de peças fui até o site da Farnell e comprei o material que não tinha aqui ou que seria mais critico na fonte. Isso inclui os eletroliticos que precisam ser especificos para fontes trabalhando nessa frequencia (capacitores com baixa ESR). A Farnell cobra caro, mas fornece os componentes com o part number correto de acordo com os datasheets. E por sorte eles também tinham os núcleos de ferrite e os carreteis que eu precisava:
Nucleos de ferrite

4. A placa de testes (nunca se acerta uma PCB de primeira) foi feita no idoso, mas confiável, Tango PCB:
Placa da fonte no Tango PCB

5. E, acreditem ou não, esta foi a primeira placa que fiz pelo processo de impressão a laser em folha de revista e passada a ferro quente.

Placa virgem e layout impresso
E sim, tive que fazer duas placas, a primeira eu não espelhei o desenho antes de imprimir (podem rir)...

6. Como é um projeto particular e só uma unidade será montada, exagerei nos componentes, com uma boa margem nas especificações para evitar problemas. A placa também ficou bem espaçosa, poderia ter ficado bem menor. Olha ela montada, mas ainda sem o transformador:

Fonte montada sem o transformador

7.  Ah, o transformador... A regra para projetos de fontes chaveadas é que o transformador precisará ser enrolado várias vezes até chegar na versão final. Até agora enrolei dois, sendo que o último tive que tirar do circuito para acertar os enrolamentos duas vezes. Fora os acertos no entreferro (Gap).

8. Comprei uma fita para transformador na China e enquanto ela não chegava tentei montar o primeiro transformador com fita isolante comum. Como a fita é muito grossa acabou que o núcleo de ferrite não entrou. O primeiro trafo ficou só no carretel mesmo:

Primeiro transformador

9. Quando a fita chegou enrolei o segundo trafo:
Segundo transformador

As presilhas plásticas estão aí para manter os núcleos fechados. Fiz isso pois já sabia que ia ter que ficar acertando o trafo depois. Quando o transformador estiver correto ele será definitivamente fechado e envernizado.

10. Claro que a fonte não ia funcionar de primeira. Já estava esperando até explodir alguma coisa na minha cara. Mas até que não foi ruim, a fonte ficou ligando e desligando. Como o trafo foi enrolado a mão ele seria o primeiro suspeito. Tirei do circuito e conferi o sentido (fase) dos enrolamentos e constatei um erro em uma das fases do primário (estava invertido). Assim um enrolamento "empurrava" o fluxo pra um lado e o outro para o outro lado (só lembrar da regra da mão direita). Não ia funcionar mesmo...

11. Corrigido a fase do primário a fonte funcionou. Bom, pelo menos com uma carga leve nas saídas. A saída de alta tensão chegou a perigosos 440V (coloquei capacitores de 450V ali). Retirei umas 20 espiras do secundário para baixar esta tensão. Com carga baixa as tensões ficaram assim:
Fonte funcionando

12. A saída de 6,3V ficou perfeita (o loop é fechado nela) e consegui os 4A nominais. No momento estou brigando com a saída de alta tensão. Tentei puxar uma corrente de uns 30mA (com um resistor de 10k na saída) e ela fica ligando e desligando. Me parece que o CI está protegendo de alguma coisa. Mas ainda não sei o que é e tenho que continuar os testes. Será a tensão do secundário refletida no primário? Temperatura? (pouco provavel, não notei nada esquentando)...

5 comentários:

  1. Respostas
    1. Obrigado Newton, bom saber que você também lê meu blog.

      Excluir
  2. olá , tenho montado um amplificador valvulado ,e tenho pesado muito em adequar uma fonte mais moderna ,com a estabilidade de uma fonte de tv talvez seja possível projetar uma ,

    ResponderExcluir

1. Alguns comentários são moderados automaticamente. Caso isso ocorra pode levar algum tempo até que eu veja e o libere.
2. Comentários fora do assunto do post podem ser apagados.
3. Não, eu não posso consertar os seus aparelhos!

Related Posts Plugin for WordPress, Blogger...